blob: 8af2f9b92d3df1c7e938f85f30ea56daeab5a309 [file] [log] [blame]
Jan Kundrátfc16f062018-08-09 19:58:55 +02001ifdef CZECHLIGHT_CLEARFOG_LEDS_BOOT
2define CZECHLIGHT_CLEARFOG_LEDS_BOOT_INSTALL_TARGET_CMDS
3 $(INSTALL) -D -m 0644 \
4 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/czechlight-clearfog-leds-boot.service \
5 $(TARGET_DIR)/usr/lib/systemd/system/
6 ln -sf ../czechlight-clearfog-leds-boot.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
7endef
8endif
9
10define CZECHLIGHT_CLEARFOG_LEDS_INSTALL_TARGET_CMDS
11 mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
12 $(INSTALL) -D -m 0644 \
13 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/czechlight-clearfog-leds.service \
14 $(TARGET_DIR)/usr/lib/systemd/system/
15 ln -sf ../czechlight-clearfog-leds.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
16 $(CZECHLIGHT_CLEARFOG_LEDS_BOOT_INSTALL_TARGET_CMDS)
17endef
18
19$(eval $(generic-package))