blob: f51b6ef76de627f83f70ff42b3f9f47acae3e52a [file] [log] [blame]
Jan Kundráte8b18112018-04-04 23:11:23 +02001CZECHLIGHT_CFG_FS_INSTALL_IMAGES = YES
Jan Kundrátde3594f2018-05-24 16:28:06 +02002CZECHLIGHT_CFG_FS_DEPENDENCIES = host-e2fsprogs
Jan Kundráte8b18112018-04-04 23:11:23 +02003
4CZECHLIGHT_CFG_FS_LOCATION = $(BINARIES_DIR)/cfg.ext4
5
6define CZECHLIGHT_CFG_FS_INSTALL_IMAGES_CMDS
7 rm -f $(CZECHLIGHT_CFG_FS_LOCATION)
8 $(HOST_DIR)/sbin/mkfs.ext4 -L cfg $(CZECHLIGHT_CFG_FS_LOCATION) $(call qstrip,$(CZECHLIGHT_CFG_FS_SIZE))
9endef
10
Jan Kundrát62dbb4a2018-04-05 20:42:09 +020011ifeq ($(BR2_PACKAGE_CZECHLIGHT_CFG_FS)-$(call qstrip,$(CZECHLIGHT_CFG_FS_SIZE)),y-)
12$(error CZECHLIGHT_CFG_FS_SIZE cannot be empty)
13endif
14
Jan Kundrát960274e2018-04-09 11:20:56 +020015define CZECHLIGHT_CFG_FS_INSTALL_TARGET_CMDS
Jan Kundrátde3594f2018-05-24 16:28:06 +020016 mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/local-fs.target.wants/
Jan Kundrát960274e2018-04-09 11:20:56 +020017 $(INSTALL) -D -m 0644 \
18 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-cfg-fs/etc-overlay.service \
19 $(TARGET_DIR)/usr/lib/systemd/system/etc-overlay.service
20 ln -sf ../etc-overlay.service $(TARGET_DIR)/usr/lib/systemd/system/local-fs.target.wants/
Jan Kundrátde3594f2018-05-24 16:28:06 +020021 mkdir -p $(TARGET_DIR)/usr/lib/systemd/system-generators/
Jan Kundrát960274e2018-04-09 11:20:56 +020022 $(INSTALL) -D -m 0755 \
23 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-cfg-fs/czechlight-cfg-mount-generator \
24 $(TARGET_DIR)/usr/lib/systemd/system-generators/czechlight-cfg-mount-generator
25 $(INSTALL) -D -m 0644 \
26 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-cfg-fs/cfg-restore-etc.service \
27 $(TARGET_DIR)/usr/lib/systemd/system/cfg-restore-etc.service
28 ln -sf ../cfg-restore-etc.service $(TARGET_DIR)/usr/lib/systemd/system/local-fs.target.wants/
Jan Kundrátff8479a2018-04-09 12:01:19 +020029 $(ifeq ($(CZECHLIGHT_CFG_FS_PERSIST_SYSREPO),y))
Jan Kundrátde3594f2018-05-24 16:28:06 +020030 mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
Jan Kundrátff8479a2018-04-09 12:01:19 +020031 $(INSTALL) -D -m 0644 \
32 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-cfg-fs/sysrepo-persistent-cfg.service \
33 $(TARGET_DIR)/usr/lib/systemd/system/
34 ln -sf ../sysrepo-persistent-cfg.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
35 $(endif)
Jan Kundrát960274e2018-04-09 11:20:56 +020036endef
37
Jan Kundráte8b18112018-04-04 23:11:23 +020038$(eval $(generic-package))