Jan Kundrát | 8ddd27f | 2018-04-05 11:14:24 +0200 | [diff] [blame] | 1 | define CZECHLIGHT_SEPARATE_BOOT_SYMLINK_BOOT |
| 2 | cd $(TARGET_DIR)/boot |
| 3 | ln -s . boot |
| 4 | endef |
| 5 | |
| 6 | ROOTFS_CZECHLIGHT_SEPARATE_BOOT_PRE_GEN_HOOKS += CZECHLIGHT_SEPARATE_BOOT_SYMLINK_BOOT |
| 7 | |
| 8 | ROOTFS_CZECHLIGHT_SEPARATE_BOOT_DEPENDENCIES = host-e2fsprogs |
| 9 | |
| 10 | define ROOTFS_CZECHLIGHT_SEPARATE_BOOT_CMD |
| 11 | rm -f $@ |
| 12 | $(HOST_DIR)/sbin/mkfs.ext2 -d $(TARGET_DIR)/boot -L /boot $@ \ |
| 13 | $(call qstrip,$(CZECHLIGHT_SEPARATE_BOOT_SIZE)) |
| 14 | endef |
| 15 | |
| 16 | ifeq ($(BR2_TARGET_ROOTFS_CZECHLIGHT_SEPARATE_BOOT)-$(call qstrip,$(CZECHLIGHT_SEPARATE_BOOT_SIZE)),y-) |
| 17 | $(error CZECHLIGHT_SEPARATE_BOOT_SIZE cannot be empty) |
| 18 | endif |
| 19 | |
| 20 | $(eval $(rootfs)) |