Sync and update the CI

Now that the logs, artifacts and essentially everything is in Swift, I'm
moving our mirror there as well. (The ironic part is that the Swift GW
is currently IPv4-only, but maybe that will change, and our VMs used to
be IPv6-only, and some of the original mirrors were IPv4-only as well...)

Here's how to seed the mirror in Swift:

 mkdir mirror
 cd mirror
 ln -s ~/work/cesnet/gerrit/github/buildroot/buildroot/dl buildroot
 cd ..
 openstack object create ci-artifacts-public mirror/buildroot/*/*tar* mirror/buildroot/*/*.zip

I wonder how we'll be dealing with cache purging, but hey, perhaps I can
claims that this is "for license compliance", yay.

There were some random build failures which I assumed to be related to
Python. They were not, it was a change in libyang which now requires an
out-of-tree build.

The cla-sysrepod update enables removal of netsnmp, something which
should reduce the space consumption a bit, and also cut the configure
time substantially.

The disk space is, however, still running rather thin, so it needs an
increase :(.

Change-Id: I14e57c0394a65e48761418abe9529bea8d1d8762
diff --git a/package/cla-sysrepo/cla-sysrepo.mk b/package/cla-sysrepo/cla-sysrepo.mk
index ddef562..07366bc 100644
--- a/package/cla-sysrepo/cla-sysrepo.mk
+++ b/package/cla-sysrepo/cla-sysrepo.mk
@@ -2,7 +2,7 @@
 CLA_SYSREPO_SITE = ssh://kundrat@cesnet.cz@gerrit.cesnet.cz:29418/CzechLight/cla-sysrepo
 CLA_SYSREPO_SITE_METHOD = git
 CLA_SYSREPO_INSTALL_STAGING = NO
-CLA_SYSREPO_DEPENDENCIES = sysrepo docopt-cpp spdlog netsnmp systemd libgpiod
+CLA_SYSREPO_DEPENDENCIES = sysrepo docopt-cpp spdlog systemd libgpiod
 CLA_SYSREPO_CONF_OPTS = -DTHREADS_PTHREAD_ARG:STRING=-pthread
 CLA_SYSREPO_LICENSE_FILES = LICENSE.md