Rename OSC devices and refactor LED setup

- on ROADM Line Degree modules, use "osc" for "eth2",
- on inline amplifiers, use "oscW" for eth2 and "oscE" for the PCIe
add-on NICs,
- otherwise, keep the name as-is (eth2)

And because I'm touching the service which sets up the LEDs, let's
convert it into a shellscript, these one-liners are starting getting
rather scary. This means that:

- I'm splitting these per-function, so SFP netlink activity is separate
from EDFA indication setup,
- correct LEDs are now used for the inline amplifier

Change-Id: Ie0a4a91a3f7e714e4a0d55124e2f5011e7cbdc6b
Task: https://tree.taiga.io/project/jktjkt-czechlight/task/793
diff --git a/package/czechlight-clearfog-leds/czechlight-clearfog-leds.mk b/package/czechlight-clearfog-leds/czechlight-clearfog-leds.mk
index 97ab75c..cc78ebc 100644
--- a/package/czechlight-clearfog-leds/czechlight-clearfog-leds.mk
+++ b/package/czechlight-clearfog-leds/czechlight-clearfog-leds.mk
@@ -14,7 +14,10 @@
                 $(TARGET_DIR)/usr/lib/systemd/system/
         ln -sf ../czechlight-clearfog-leds.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
 	$(CZECHLIGHT_CLEARFOG_LEDS_BOOT_INSTALL_TARGET_CMDS)
-	cp $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/clearfog-test-leds.sh \
+	cp \
+		$(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/clearfog-test-leds.sh \
+		$(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/init-leds-edfa.sh \
+		$(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/czechlight-clearfog-leds/init-leds-sfp.sh \
 		$(TARGET_DIR)/usr/bin/
 endef