Update velia

Due to recent changes in velia, where we split the daemon into several
smaller ones, this commit adds service files for those new daemons
(veliad-{health,hardware,system}) and also installs a new YANG model
that is needed for the veliad-system functionality.

Also sync all dependencies, that's required due to the way the build
system picks versions of sysrepo, etc. And that in turn required a
sanity sweep over unit dependencies.

NOTE: anything that uses sysrepo must be listed in the reset-sysrepo
package, otherwise Bad Things(TM) happen.

Change-Id: I5aae8da2d7af95ead80070ad4cd18d7143e0f736
Co-authored-by: Jan Kundrát <jan.kundrat@cesnet.cz>
diff --git a/package/velia/velia.mk b/package/velia/velia.mk
index b09a0e9..a32c38e 100644
--- a/package/velia/velia.mk
+++ b/package/velia/velia.mk
@@ -7,16 +7,22 @@
 VELIA_LICENSE = Apache-2.0
 VELIA_LICENSE_FILES = LICENSE.md
 
+define VELIA_PREPARE_SERVICE
+    $(INSTALL) -D -m 0644 \
+            $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/velia/$1.service \
+            $(TARGET_DIR)/usr/lib/systemd/system/
+    ln -sf ../$1.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
+endef
+
 define VELIA_INSTALL_INIT_SYSTEMD
         mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
         $(INSTALL) -D -m 0644 \
-                $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/velia/velia.service \
-                $(TARGET_DIR)/usr/lib/systemd/system/
-        ln -sf ../velia.service $(TARGET_DIR)/usr/lib/systemd/system/multi-user.target.wants/
-
-		$(INSTALL) -D -m 0644 \
                 $(BR2_EXTERNAL_CZECHLIGHT_PATH)/package/velia/max_match_rules.conf \
                 $(TARGET_DIR)/usr/share/dbus-1/system.d/
+
+        $(call VELIA_PREPARE_SERVICE,velia-health)
+        $(call VELIA_PREPARE_SERVICE,velia-hardware)
+        $(call VELIA_PREPARE_SERVICE,velia-system)
 endef
 
 $(eval $(cmake-package))